Can't install libraries

Help with questions or problems.

Can't install libraries

Postby Stoeving » January 4th, 2017, 1:19 pm

Hello

After many, many years i tried to reinstall PGA2000(titanium edition) on Windows 10. The game works fine, and I'm playing well.

BUT I can't install new libraries and therefore new courses. When I try, I get the message that the library needs to be installed to a different directory. But I've tried installing them almost anywhere, and without any luck.
The funny thing is that I succeeded in installing 4-5 courses(with libraries) a few days ago, but they are gone now. Almost like the game cleaned all new courses out. And in the list of libraries(and courses) in the course manager, the first 10-15 lines are empty.

Has anyone tried this? And does someone have an idea about what's going on?
Stoeving
Range Rookie
 
Posts: 3
Joined: January 4th, 2017, 1:12 pm

Re: Can't install libraries

Postby SteveHorn » January 5th, 2017, 11:53 am

Stoeving ! Many times I've got the message "library needs installed to a different directory" but never have I had courses go missing. I keep many libraries in a file in "MY DOCUMENTS" because I uninstall libraries not being used at that time frequently to help avoid conflicts. Sometimes a library that I try to install from that file wont install because it already is in the PGA 2000 folder but needs reinstalled from that file not the my documents file. If that happens I get that message and have to install from the PGA 2000 file, Hope this helps.
SteveHorn
Legend of Golf
 
Posts: 897
Joined: November 18th, 2010, 8:24 am

Re: Can't install libraries

Postby Stoeving » January 5th, 2017, 12:10 pm

Something seems completely wrong. I might have to reinstall.
I installed Augusta National(and several others) and played a round, but now it's not there. Instead there's a list of 13 blank lines at the top of my courses list at the left side of my Course manager.

But let me try to understand :

1 : When I install a course library (succesfully) it should appear in the Course Manager on the list of libraries on the right? No matter to which folder I install it?

2 : When I have a course and a course library, should I install the library first, and then the course afterwards? Or can I highlight both(or more) and install them at the same time?
Stoeving
Range Rookie
 
Posts: 3
Joined: January 4th, 2017, 1:12 pm

Re: Can't install libraries

Postby SteveHorn » January 6th, 2017, 9:54 am

Stoeving! All of the courses I have on disk are compressed with most of the libraries (NOT ALL) of the libraries needed for any course I wish to play. This is a .xcr file. Any course you download from this site won't have any libraries compressed to a course unless they created a new library for that course. A course with no compressed libraries is .crs file. A library only file is .lib and if installed will appear on the right side of the course manager. You can install any of these 3 file types from your computer wherever you choose to have these files on your computer so long as it isn't already located in your Sierra PGA 2000 folder or files. If its in this area you must install from that folder.
It sounds like your antivirus or security is conflicting with your game. This happens more and more with older games or files on new systems. Before I can play a round my security has a window pop up asking me if" I want this unknown publisher to make changes to my computer". If this window pops up for you always click on (yes).
Try uninstalling and reinstalling with your antivirus and security OFF. Then run the game with it still off and see if it works
SteveHorn
Legend of Golf
 
Posts: 897
Joined: November 18th, 2010, 8:24 am

Re: Can't install libraries

Postby Stoeving » January 7th, 2017, 2:46 am

OK. Thank you.
I think I might reinstall the game. Or just play the ca. 30 courses that came with the game. They're working fine.

It looks like I'm doing it right, and then something is interfering with the game.
I downloaded(and saved) about 40 courses some 13-14 years ago, and it's those courses that I'm trying to install now. They where mostly compressed courses.
It worked the first day, but as I said, now they're gone.
Stoeving
Range Rookie
 
Posts: 3
Joined: January 4th, 2017, 1:12 pm

Re: Can't install libraries

Postby BrianZ111 » January 9th, 2017, 1:10 pm

I've run into this disappearing courses problem on my Windows 8 laptop. Some people seem to go without problems but this seems be an issue with newer windows OS's where the registry entries for installed courses get corrupted. Uninstalling and reinstalling the game does work but it will probably just return again. Another work around is to change windows accounts and reinstall the courses. (For example running course manager and the game as admin is typically a different account or you could create a whole new windows user account to run the game under) This works because each account gets its own location in the registry where the list of installed courses is saved and the new account won't have this corrupted yet. Unfortunately every time they disappear on an account with this method you'd have to create a new windows account. It might be possible to save the registry keys for PGA 2000 while everything is good yet and if and when everything goes bad run the saved registry key file to reinstate the old keys. Unfortunately I don't really know what causes the corruption to begin with and haven't had time to try to figure this out further yet but maybe this will point you in the right direction to figure it out. Sorry I can't help more.
BrianZ111
Legend of Golf
 
Posts: 637
Joined: November 12th, 2010, 12:59 pm
Location: Wisconsin

Re: Can't install libraries

Postby moodybluer » May 9th, 2017, 2:28 am

I seem to be having the same problem. Over the last 16 years I've installed over 1600 courses, with 450 kept current. Recently, I noticed that 180 of them have disappeared. This includes all courses since 2012. I, too, keep getting the "install in a different directory" message. Stranger still, I installed "Calypso" tonight and it worked!
moodybluer
Novice
 
Posts: 7
Joined: December 5th, 2010, 12:59 pm


Return to Technical Help

Who is online

Users browsing this forum: No registered users and 1 guest

cron